Bitbucket 8.16+ requires fix for defect Java mail library
Incident Report for SNotify
Update
Atlassian has released Bitbucket 8.19.0, but unfortunately still hasn't fixed the issue – we keep reminding them
Posted Mar 12, 2024 - 11:25 UTC
Update
Atlassian still hasn't fixed the issue in the latest Bitbucket 8.18.0 – we keep reminding them
Posted Feb 06, 2024 - 09:08 UTC
Update
Atlassian has confirmed the issue and announced that they will provide a fixed version. We keep monitoring their progress.
Posted Jan 23, 2024 - 16:06 UTC
Monitoring
In their latest Bitbucket 8.16.0 release, Atlassian has updated the Java mail library. Unfortunately, they updated it to version 1.6.2, which is known to have a bug, and this bug breaks S/Notify functionality. However, there is a working fix for this.

If you want to update to Bitbucket 8.16, please follow our instructions at https://help.savignano.net/snotify-email-encryption/known-limitations#KnownLimitations-MalfunctioningJavaMailLibrary

We have filed a bug report with Atlassian, and we are now awaiting and monitoring their fix.
Posted Nov 29, 2023 - 10:57 UTC
This incident affects: S/Notify for Bitbucket.